power jack - Manufacturers, Suppliers & Exporters

Total 3408 products found
Diesel Generator Set with Light Tower

Delivery Time 30 Days Package Pack in plywood pallet,1750*1150*1150MM,12 Sets in 20'GP Supply Ability 100 Set/Sets per Month Minimum Order Quantity 1 Set/Sets Payment Terms L/C,T/T Port Fuzhou Fob Price US$1-9000Fuzhou Lamp of mobile light tower Metal halide floodlight Model Numb

Fuzhou Camel Power Co., Ltd.   

HOME DVD PLAYER ; 5 DISC DVD CHANGER

Delivery Time 35 DAYS Package GIFTBOX / CARTON Supply Ability 10,000 Piece/Pieces per Month Minimum Order Quantity 50 Piece/Pieces Payment Terms L/C,T/T Port Zhuhai ,China Use Professional Video Output S-Video Output Audio Output Virtual 5.1 Channel Use Home Use Professional Vide

Zhuhai Sanjin Industrial Co., Ltd.   

Digital photo frame

Delivery Time 15-25days Package color box size 350*90*300mmQTY/Carton 10 PcsCarton Size 610*500*375mm20FCL 2460pcs40FCL 5090Pcs40HQ 5960Pcs Supply Ability 600 Set/Sets per Day Minimum Order Quantity 500 Set/Sets Payment Terms L/C,T/T,Western Union,Cash Port Shenzhen Frame Materi

Shenzhen Sawink Technology Co., Ltd.   

Brand New Ebook Reader H anlin

Minimum Order Quantity 10 Piece/Pieces Payment Terms T/T,Western Union Port Soekarno Hatta Fob Price US$120-130Soekarno Hatta Place of Origin Jakarta Raya Indonesia Place of Origin Jakarta Raya Indonesia Brand New, Manufacture Sealed Ready To Ship Hanlin eReader V3 with Vizplex D

Setiawan Indo Gadget   

AIPTEK HD 1080p Digital Camcorder--AHDZ600

Delivery Time leadtime 6weeks Package V5Z3S, AIPTEK BRAND Qty/Carton 20pcs // N W./CTN 18.0kgs // G W./CTN 19.1kgs // MEAS. 41*40*37 cm Minimum Order Quantity 100 Set/Sets Payment Terms L/C,T/T Color Black Video Capture Yes Memory Card Type SD Card Image Stabilization Yes Optical

AIPTEK TAIWAN   

Vivitar Camera

Video Capture Yes Screen Size 2-3" Video Capture Yes Image Stabilization Yes MegaPixel 10.0 - 20.0MP Video Capture Yes Screen Size 2-3" Video Capture Yes Image Stabilization Yes MegaPixel 10.0 - 20.0MP Vivitar DVR-560G 5.2MP 6-in-1 Multi Functional Camera with 2.0" LCD (mp3 playe

NUTECH TRADING USA INC   

16GB 16G MP3 MP4 player USB 2.0 FM Movie AMV JF81-16S

Supply Ability 100 Piece/Pieces per Day Minimum Order Quantity 10 Piece/Pieces Port Beijing Fob Price US$39-46Beijing Function Voice Recorder Function Voice Recorder 16GB 16G MP3 MP4 player USB 2.0 FM Movie AMV JF81-16S Features 65000 true color display. Support multiple music fo

Zhangwenli   

Wireless ADSL Router DG834GV

Wireless ADSL Modem Router 54Mbps (DG834G) RFC Support - IPSec tunnel mode (RFC 2401) (pass through mode), IP v.4 - DHCP server (RFC 2131) - DHCP client (RFC 2131) - NAT (many-to-one) (RFC 1631) - IP Control Protocol (RFC 1332) - Bridged Ethernet Encapsulation (RFC 1483, 2684) -

Winner Trade   

CPU for SL9SG (Intel Core 2 Duo Mobile T5600)

Delivery Time immediately after payment Package secure. Supply Ability 500 Piece/Pieces per Month Minimum Order Quantity 10 Piece/Pieces Payment Terms T/T,Western Union Port Shenzhen Model Number SL9SG Brand Name Intel Main Frequency 1.833 GHz Socket Type Socket 478 L2 Cache 2MB

Shenzhen L&P Technology Co., Ltd.   

Laptop intel CPU Processor

Delivery Time as soon as payment Package safe and secure package with plastic box Supply Ability 400 Piece/Pieces per Day Minimum Order Quantity 50 Piece/Pieces Payment Terms T/T,Western Union,PAYPAL Port shenzhen Main Frequency 1.83 GHZ Socket Type Socket AM2+ L2 Cache 2MB Proce

Shenzhen L&P Technology Co., Ltd.   

NVIDIA GEFORCE4 420GO CPU

Delivery Time as soon as payment Package 1)30pcs with one box2)safe and standard package Supply Ability 2000 Piece/Pieces per Day Minimum Order Quantity 100 Piece/Pieces Payment Terms T/T,Western Union,paypal Port shenzhen Model Number NVIDIA GEFORCE4 420GO Brand Name *NVIDIA Mai

Shenzhen L&P Technology Co., Ltd.   

AMD Athlon XP 2200+ CPU

Delivery Time as soon as payment Package 1)30pcs with one box2)safe and standard package Supply Ability 2000 Piece/Pieces per Day Minimum Order Quantity 100 Piece/Pieces Payment Terms T/T,Western Union,paypal Port shenzhen Model Number AMD Athlon XP 2200+ Brand Name *AMD Main Fre

Shenzhen L&P Technology Co., Ltd.   

Laptop CPU processor

Delivery Time as soon as payment Package 1)30pcs with one box2)safe and standard package Supply Ability 500 Piece/Pieces per Day Minimum Order Quantity 50 Piece/Pieces Payment Terms T/T,Western Union,paypal Port shenzhen Main Frequency 1.83GHz Socket Type Socket AM2+ L2 Cache 2MB

Shenzhen L&P Technology Co., Ltd.   

10.2 inch VIA mini laptop, cpu:VIA, 160G,WIFI, card reader,3 USB ports,LOW PRICE

Brand Name GNEX Optical Drive Type Other Graphics Card Type Integrated Card Memory Capacity 1GB Hard Drive Capacity 160GB Processor Type Other Processor Brand VIA Screen Size 10" Place of Origin Guangdong China (Mainland) Model Number GNEX-910 Brand Name GNEX Optical Drive Type O

Gnex Technology Co., Ltd.   

MINI Laptop

Delivery Time according to the quantity your ordered Package safety packing Supply Ability 1000 Unit/Units per Day Minimum Order Quantity 2 Unit/Units Payment Terms L/C,T/T Port shenzhen Fob Price US$225-268shenzhen Brand Name HZC Optical Drive Type CD-ROM Graphics Card Type Inte

Shenzhen Huazhicheng Plastic Mold Co., Ltd.   

4. 3 GPS Navigation

Function Touch Screen Screen Size 4.3 inch Use Automotive Type Gps Navigator Function Touch Screen Screen Size 4.3 inch Use Automotive Type Gps Navigator 4. 3 inch premium GPS for Export KOPEX please send us your inquiry, we will reply soon very shortly. Sample available with Ch

E.M.H Co Ltd   

Car GPS , Car GPS Navigation System

Delivery Time 5-7 business days Package Color Box Size 170x130x135 mm N W. 0.66 KG Supply Ability 10,000 Set/Sets per Month Welcome you and your small order Minimum Order Quantity 5 Set/Sets Welcome you and your small order Payment Terms T/T,Western Union,paypal Port shenzhen Fo

Shenzhen Windstone Electronics Co., Ltd.   

4.3 GPS Navigation System with CMMB/DVBT function and wireless reverse camera

Delivery Time 2~3 days Package standard packing Minimum Order Quantity 10 Piece/Pieces Payment Terms T/T,Western Union Port hongkong Fob Price US$65-150hongkong Model Number 4301 Brand Name ztqx Place of Origin Guangdong China (Mainland) Function Touch Screen Screen Size 4.3 inch

ZTQX INTERNATIONAL LIMITED   

7 inch gps

Delivery Time in 3 days Package retail package Supply Ability 50000 Piece/Pieces per Week Minimum Order Quantity 10 Piece/Pieces Payment Terms T/T,Western Union,MoneyGram,paypal Port shenzhen Fob Price US$29-99shenzhen Memory 64MB SDRAM Built-In Resolution 480x234 Brand Name oem

Eunion Industrial Co., Ltd.   

Car DVD Player with LCD(built-in GPS)

Delivery Time 3-15 days Supply Ability 5000 Piece/Pieces per Month Minimum Order Quantity 100 Piece/Pieces Payment Terms T/T,HSBC Port ShenZhen Built-in GPS Built-in TV Tuner 7" Touch-screen TFT LCD Built-in BlueTooth Model Number DA-971 Brand Name A&V and OEM Place of Origin Gua

ZhengQiLong DaWei (ShenZhen) Electronic Manufactory